View Issue Details

IDProjectCategoryView StatusLast Update
0001721OXID eShop (all versions)4.07. Source code, Testpublic2013-08-30 15:25
Reporteralfonsas_cirtautas 
PriorityurgentSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.2.0 revision 23610 
Target VersionFixed in Version4.5.1 revision 38045 
Summary0001721: Missing functionality for custom component handling
Descriptionin oxubase we have array for custom components:

Names of components (classes) that are initiated and executed
before any other regular operation. User may modify this himself.

protected $_aUserComponentNames = array();


The only way to set this array is to override it in view class.
Creating global custom component will require to extent/modify all existing views.

Better solution needed.
TagsNo tags attached.
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0002865 resolvedarvydas_vapsva noncachable user components are not inititialised in initNonCacheableComponents 

Activities

tjungcl

2011-05-11 08:07

reporter   ~0004540

since this issue is open for over a year now:

For a start please load aUserComponentNames from config.inc

Holger Kohnen

2011-06-18 08:09

reporter   ~0004745

+1 for defining user-components in config.inc.php.
This is easy to fix.
Can someone increase the severity please, because this bug makes use of components for extensions useless. Most people extend viewconfig thousend of times but in many cases it would be cleaner to create a user component.