View Issue Details

IDProjectCategoryView StatusLast Update
0002649OXID eShop (all versions)3.1. Design, GUI, UXpublic2011-06-27 10:27
Reportertjungcl 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product VersionPast development 
Target VersionFixed in Version4.5.1 revision 38045 
Summary0002649: shop very slow in IE8
Descriptiondoing anything (opening productlist, startpage, details, adding to basket, opening checkout) in IE8 is dramatically slower than in any other browser (did not try ie6+7+9).

FF4 and Chromium are done within about a second (often faster).
IE8 needs about 4-6 seconds for the same click.

I know IE8 is slow, but since 40% of our visitors use it, this is near to inacceptable.
TagsNo tags attached.
Theme
BrowserInternet Explorer 8.x
PHP Versionany
MySQL Versionany

Relationships

has duplicate 0002813 closeddainius.bigelis Azure Theme: Poor performance in IE 8 
related to 0002853 resolvedLinas Kukulskis Top of the shop mouseOver does not work with IE8 

Activities

tjungcl

2011-05-31 15:54

reporter   ~0004667

Last edited: 2011-05-31 15:55

View 3 revisions

I accidently found the reason for the lack of speed in IE:

The CSS3 emulator "PIE.htc" is assigned to a whole bunch of selectors.
(When you add background-color:red!important to the same ruleset and then closely look on the site you'll see, that most elements are red.)

In effect several hundret html elements in every view have assigned the PIE behaviour. PIE.htc is a javascript library emulating CSS3, which initially runs for each element on page-load and while using a loaded page progresses every CSS event such as mouseover, mouseover, click, etc.

It is great that such a tool exists, but if you think about it, its quite insane: this piece of javascript code emulates the whole CSS3 implementation and runs hundrets of times simultaniously if used as excessivly as in the Azure theme.

To try it out just remove the whole PIE definition in the ie.css.
Then check out IE performance and you will see that everything runs fast and smooth.
Obvious problem: Now it looks quite different. But I think you will just have to rebuild some of the layout with IE specific CSS definitions instead of relying completly on PIE.

dainius.bigelis

2011-06-02 13:47

reporter   ~0004675

Hi,

thanks for your hint. We also detected that this "Pie" makes significant slowdown in the shop. And we are checking what other options can be to make some stuff still displayed in other ways. Solution will be prepared for next Patch.

Best regards,

Linas Kukulskis

2011-06-27 10:27

reporter   ~0004772

removed pie