View Issue Details

IDProjectCategoryView StatusLast Update
0002644OXID eShop (all versions)2.2. Shop settingspublic2013-02-07 14:31
Reportersarunas_valaskevicius 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product VersionPast development 
Target Version4.7.3 / 5.0.3 revision 54408Fixed in Version4.8.0_5.1.0_beta1 
Summary0002644: usability issue while assigning payments in admin
Descriptionwhile if you dont assign any countries to payment and it gets selected for all countries, you have to assign user groups explicitly. This hardens the configuration works.
TagsPayment
ThemeBoth
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

has duplicate 0003017 resolveddainius.bigelis User/group assignment in payment methods works differently than all other assignments 
has duplicate 0004965 closedjurate.baseviciene Assign a user group needed in payment methods 

Activities

ray

2013-01-24 08:57

reporter   ~0008321

correct - but keep in mind that this was "ever since" so changing the logic is not an option for a patch release

maybe it would be better to clearly point out in documentation as well as in tootips within backend

leofonic

2013-01-24 11:18

reporter   ~0008322

This is the same as 0003017. Changing this would not break existing rules, the logic would be the same as before if user groups are assigned.

aurimas.gladutis

2013-02-07 14:31

reporter   ~0008388

Changed logic, so that when no groups are assigned, payment is available for all groups. Launching this only in next major version, because this does change the current logic of this place.