View Issue Details

IDProjectCategoryView StatusLast Update
0002127OXID eShop (all versions)2. ----- eShop backend (admin) -----public2012-12-07 13:59
Reporterd3 
PriorityimmediateSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.4.2 revision 29492 
Target VersionFixed in Version4.4.5 revision 31315 
Summary0002127: shipping cost rules: query time - increases exponentially
DescriptionShop Settings / Shipping Cost Rules / Products /-> Assign Products
The more articles you assign to a "shipping cost rule", the more time is needed for this query execute(Ajax List is loading):

SELECT count( * ) FROM oxarticles
WHERE 1
AND oxarticles.oxparentid = ''
AND oxarticles.oxid NOT
IN (
SELECT oxarticles.oxid
FROM oxobject2delivery
LEFT JOIN oxarticles ON oxarticles.oxid = oxobject2delivery.oxobjectid
WHERE oxobject2delivery.oxdeliveryid = "286463b824829f5e8.06658778"
AND oxobject2delivery.oxtype = "oxarticles"
)
Steps To Reproduce- I got a dump from a customer with 0000154:0000100.000 articles.
- I assigned 1520 (oxobject2delivery / incl. variants) articles to a "shipping cost rule"
- I reopened the Ajax List ( now it is time to wait ).
- On the MySQL server you can see, with "SHOW PROCESSLIST;", what the query does: it produces 108710 rows in the result set (41 min 34.68 sec)
- Second try with a new db. 0000011:0000046.087 articles and 853 assigned articles (no variants): i cancled after 3403 seconds
TagsAJAX
Theme
BrowserAll
PHP Versionany
Database Versionany

Relationships

related to 0001565 resolvedalfonsas_cirtautas Only 2500 items will be displayed in Ajax lists 
related to 0002152 resolvedarvydas_vapsva AJAX lists are almost unusable when there are lot of products 

Activities

d3

2010-09-23 18:02

reporter   ~0003547

the numbers are:
0000154:0000100.000 = 100000
0000011:0000046.087 = 46087

dainius.bigelis

2010-10-11 16:06

reporter   ~0003578

I assigned about 200 articles and when opened AJAX list, needed to wait about 2 minutes with status "Loading..." (in the product list frames).
So this place should be fixed, because when more items are assigned - it is not usable at all.

arvydas_vapsva

2010-11-02 17:41

reporter   ~0003661

fixed