View Issue Details

IDProjectCategoryView StatusLast Update
0001985OXID eShop (all versions)1.11. Private Sales, Invitationspublic2010-08-10 11:07
Reportersimon_stark 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.4.0 revision 28699 
Target VersionFixed in Version4.5.0_beta3 
Summary0001985: "About Us" not reachable without being logged in if Private Sales Login is active
DescriptionIf Private Sales Login is active, and you aren't logged in, the "About Us"-Page not reachable (Terms & Conditions is, by the way)
Steps To Reproduce-Activate Private Sales Login in Backend
-try http://demoshop.oxid-esales.com/community-edition/Impressum/ without being logged in.
Additional Information-
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
MySQL Versionany

Activities

arvydas_vapsva

2010-07-21 10:24

reporter   ~0003286

Since next release you will be able to write a module for oxcmp_user::_checkPsState() method and define your own rules and exceptions.

marco_steinhaeuser

2010-08-03 15:05

administrator   ~0003347

Workaround seen here:
http://www.oxid-esales.com/forum/showthread.php?t=6087&page=2#post36718

In views/content.php line 205 replace:

                     $oContent->oxcontents__oxloadid->value != "oxagb" &&

by
                     $oContent->oxcontents__oxloadid->value != "oxagb" &&
                     $oContent->oxcontents__oxloadid->value != "oximpressum" &&

arvydas_vapsva

2010-08-03 16:33

reporter  

modcontent.php (2,907 bytes)

arvydas_vapsva

2010-08-03 16:33

reporter   ~0003349

Reminder sent to: simon_stark

You can try attached module as quick fix.

arvydas_vapsva

2010-08-04 16:24

reporter   ~0003350

Last edited: 2010-08-04 16:28

View 4 revisions

So since next release you will be able to define contents which can be viewed by non logged in users or users which did not accept "Terms and Conditions" by writing a module for content.php and overriding content::$_aPsAllowedContents array. Currently its value is:

$_aPsAllowedContents = array( "oxagb", "oxrightofwithdrawal", "oximpressum" );