View Issue Details

IDProjectCategoryView StatusLast Update
0001917OXID eShop (all versions)1. ----- eShop frontend -----public2012-12-10 14:37
Reporteroxalo 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.3.0 revision 26948 
Target VersionFixed in Version4.4.5 revision 31315 
Summary0001917: Inappropriate Error Reporting on SMTP errors
DescriptionIn functions like sending email for newsletter double-optin or forgotpwd, errors based on faulty SMTP configuration (eg. username given, but no password) or faulty SMTP communication do not get reported appropriately.

Errors reported are either nil or assigned to false causes (faulty email address or whatever).

Since faulty SMTP config is a source of many intransparent problems (lenghty sending of order confirmations for example), this should be corrected.

Currently, if email sending via SMTP cannot be done, source just switches mail sending over PHP mail function and throws no errors about that.
In that case, when email sending via SMTP failed, the error messages should be tracked and sent via email (when switched to PHP mail function) to eShop admin.
TagsNo tags attached.
Theme
BrowserAll
PHP Versionany
Database Versionany

Activities

rimvydas_paskevicius

2010-10-04 16:42

reporter   ~0003569

Added additional checking to oxEmail::send() if sending by smtp fails. If yes - mail with smtp error message will be sended to shop owner.

marco_steinhaeuser

2010-11-23 11:17

administrator   ~0003724

Seems like only half of the error message is shown like reported here:
http://www.oxid-esales.com/forum/showthread.php?t=7525#post44722

A real error message (from server) is missing, for example "550 Mail Relay not allowed"

rimvydas_paskevicius

2010-11-26 14:41

reporter   ~0003741

Fixed getting smtp error: when smtp error occurs, oxemail also tries to send mail using "mail()" method. If mail successfully was sent, smtp error message setted previously was reseted. So now smtp error email will be sent to owner instantly when sending by smtp will fail.