View Issue Details

IDProjectCategoryView StatusLast Update
0001245OXID eShop (all versions)2. ----- eShop backend (admin) -----public2009-09-21 15:53
ReporterSpritje 
PriorityhighSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version4.1.5 revision 21618 
Target VersionFixed in Version4.1.6 revision 22740 
Summary0001245: Error occurs when trying to send Newsletter
DescriptionI reproduce following behaviour with a costumer:

When trying to send newsletter from the Admin, it fails and the error message occurs:
Warning: Cannot modify header information - headers already sent by (output started at [shoppath]/admin/newsletter_send.php:117) in [shoppath]/views/oxshopcontrol.php on line 300

Such exception should be handled and must not break newsletters sending.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

2009-08-26 11:54

 

admin.JPG (189,357 bytes)
admin.JPG (189,357 bytes)

d3

2009-08-26 20:44

reporter   ~0001531

In Newsletter it should be our problem in bugtrack 0001241 because class method can't be called.
In article-adminarea perhaps any class/method or something other is failed.
If you see the frontend you can click to any admin-tab and you should see displayed the real problem in the list-frame of the admin.

@developers:
You should disable the redirect in adminarea. This freature is fine in shopfrontend but not in admin because the shopowner cant see the real failure.

dainius.bigelis

2009-08-27 09:54

reporter   ~0001537

Now reproduced similar case with FireFox 3.0 also, but only when clicked on (in Admin) Customer Info -> Newsletter -> selected newsletter, and then Clicked on few of displayed tabs: HTML, TEXT, Preview, Selection... no matter in which order (after 2-3 clicks user is loged out).

birute_meilutyte

2009-08-27 10:12

reporter   ~0001539

looks like newsletter sending fails if some of emails are invalid ("admin" from demo data). anyway, such exception should be handled and must not break newsletters sending.

problem sending to : admin

Warning: Cannot modify header information - headers already sent by (output started at /xxxx/PE/admin/newsletter_send.php:117) in /xxxx/PE/views/oxshopcontrol.php on line 300

arvydas_vapsva

2009-08-27 13:42

reporter   ~0001547

Fixed "Warning: Cannot modify header information" problem, but cant fix other, because cant reproduce myself and nobody can describe exact steps.

Someone can define use case how to reproduce problem each time?

dainius.bigelis

2009-09-21 15:52

reporter   ~0001798

Description changed to match the problem which was fixed (about the error "headers already sent...").

arvydas_vapsva

2009-09-21 15:53

reporter   ~0001799

fixed