View Issue Details

IDProjectCategoryView StatusLast Update
0007478OXID eShop (all versions)2.2. Shop settingspublic2023-06-13 13:46
Status resolvedResolutionno change required 
Product Version7.0.0 
Target VersionFixed in Version 
Summary0007478: Exception after Setup via Browser
DescriptionWith the normal setup i got this Exception:

>> OXID Logger.ERROR: Could not find language abbreviation for language-id 0! No languages available

The Admin and Frontend are not accessible.

With the setup in the CLI the Shop is accessible, and all is fine.

Is there a problem with the new parameter "--language"?

TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined



2023-06-05 13:26

administrator   ~0015202

Dear d3,

on my reference system (PHP 8.0 and PHP 8.1) I can't find any problems when I run the setup in the browser.

I have tested installation in english and german.

Could you please check your system requirements
and check if all folders and databases are clean and full access rights before installation?

Best Regards



2023-06-05 14:07

reporter   ~0015203

Last edited: 2023-06-05 14:26

View 2 revisions

I found differences in the oxconfig table between the two setups.

The free search for long
outputs 8 entries in the setup with the CLI.

Via the normal setup I only get the entry:

The views are not generated.



2023-06-05 14:30

administrator   ~0015204

Dear D3,

as mentioned before, I can't reproduce this behavior on my reference system.

I am installing a new store via composer create project, I have tried community edition, professional edition and an enterprise edition.
I ran the setup through the browser and tried different settings, e.g. different languages.

Please provide information on how to reproduce this issue and check your environment for problems. in your logs or otherwise.

Best Regards

QA - SG -


2023-06-05 14:54

reporter   ~0015205

Last edited: 2023-06-05 14:55

View 2 revisions

Try it again, and use the option to install the demo data.

With demo data, you will have no data from initial_data.sql.



2023-06-05 15:02

administrator   ~0015206

Dear D3,

i also installed with demo-data and without demo-data.

no problems detetected.

Best Regards


2023-06-06 10:42

reporter   ~0015209

I have the same problem.

is there a quickfix?


2023-06-06 10:49

reporter   ~0015210

perform the setup without demodata.
And execute the initial_data.sql.


2023-06-06 11:44

reporter   ~0015211

Thanks d3.

Installing without demodata worked but after it installing the demodata with command line didn`t work too.
So I had to find another way to "find" the initial_data.sql.

To make it "more funny". Installing the shop WITH demodata does not install demodata. Tables stay empty.


2023-06-06 12:45

reporter   ~0015212

Last edited: 2023-06-06 12:45

View 2 revisions

I am no composer specialist, but:

oxid-esales/oxideshop-metapackage-ce v7.0.0 requires oxid-esales/oxideshop-demodata-ce v8.0.0 -> found oxid-esales/oxideshop-demodata-ce[v8.0.0] but it conflicts with your root composer.json require (v7.0.0).


2023-06-06 15:57

administrator   ~0015215



2023-06-07 14:09

administrator   ~0015220

We could reproduce the issue if the PHP Version of the CLI is different to the web server PHP version.
To check if that's the case in your project, execute the command 'which php' and check if the PHP version is different to the web server (e.g. phpinfo()).

While installing the demo data, the setup executes commands via the PHP function exec(), which is using the default PHP installation on the server.

We will enhance the documentation and we are checking further measures to handle such a case. But currently it looks like the system requirements aren't met and that's the cause of this issue.

@d3, please run the check and let us know what the result was.


2023-06-07 14:38

reporter   ~0015221

if I see that the system requirements are all ok before starting the setup routine, then I expect that everything is ok. I work with OXID Shops since more then 20 years and I never had this issue.

Checking with which php I have no different Versions.

And if something goes wrong within the setup process, why is there no exception?


2023-06-08 09:18

reporter   ~0015222

I can't speak for all our testinstallations.
But for the most, we have this think with the different php version.

.htaccess: AddHandler php-fastcgi8.0 .php .phtml
composer: /usr/local/php8.1/bin/php composer install

which php: /home/xxx/bin/php
php -v: 7.4



2023-06-13 13:46

administrator   ~0015288


We take the following actions:
1) Enhance the documentation of the system requirements to rise awareness of the eventually third installed PHP version on a server.
2) Check if we either get rid of the PHP method exec() at all, check the PHP version of the default path or pass through the output of the method to be able to throw an exception.

Since the code works fine if all system requirements are met, this bug entry will be closed as no changes are required. But we opened an issue regarding 2) to enhance the code to avoid the case that a third PHP installation might be used.