View Issue Details

IDProjectCategoryView StatusLast Update
0000745OXID eShop (all versions)1.04. Content, static (register, contact etc.) pagespublic2009-03-30 15:42
Reportersigmarkress 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.1.0 revision 15990 
Target VersionFixed in Version4.1.0 revision 17976 
Summary0000745: cms page title empty
Descriptionif you click on the cms-page-link in shop the title is empty.
if you reload the page "F5" the title is filles with the correct text.
Steps To Reproducesave 2 new cms-page to main menu.
and click in the shop.
switch between the cms-pages... the title is empty

Legen Sie 2 eine neue CMS Seite für das Hauptmenü an, dann gehen Sie in Ihren Shop und klicken auf den Link zur CMS Seite. Der Titel der CMS Seite ist nicht vorhanden. Er wird erst nach einem Reload mit F5 sichtbar. Wenn Sie zwischen beiden CMS Seiten wechseln taucht das Problem erneut auf.

TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

2009-03-26 08:37

 

cms-page.jpg (106,140 bytes)
cms-page.jpg (106,140 bytes)

dainius.bigelis

2009-03-26 17:11

reporter   ~0000644

Reminder sent to: sigmarkress

Hi,

We tried this case but cannot reproduce the problem - the cms page title is loaded correctly.
Could you please describe in steps how to reproduce this case start to end?

Best regards,

sigmarkress

2009-03-26 23:01

reporter   ~0000646

hi, please go into your demo shop http://demoshop.oxid-esales.com/professional-edition/admin and create in Admin Area 2 NEW CMS-Pages these 2 pages you put it into mainmenu.

now you go to http://demoshop.oxid-esales.com/professional-edition/ and click at one of the new cms links.

now you see, the title is hidden. after a reload PRESS F5 the title is visible.

if you can not reproduce the problem we can do a netviewer and is show you the problem live.

greets

dainius.bigelis

2009-03-27 09:34

reporter   ~0000648

Reproduced the case (also localy). Problem occurs only when new cms is created but (!) not only in one language (not copied to the other language).
So it looks like at the first time it tries to load the page title from other language, when it not exists.

arvydas_vapsva

2009-03-30 15:42

reporter   ~0000653

Shop language selection (flags in front-end) uses SEO urls. According to code oxUBase::_getSubject() method returns current view object, which is used in oxUBase::getLink() to load seo data. In case view object language does not match preferred one- object is reloaded and later same object is used in view etc. So i've added language check, and if languages does not match - new, not referred to view, object is created, loaded and further used for SEO urls.