View Issue Details

IDProjectCategoryView StatusLast Update
0007400module PayPal Checkoutmodule PayPal checkout - subpublic2023-01-23 19:48
Reporterdominik_ziegler 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version2.2.2 / 1.2.2 
Target VersionFixed in Version2.2.3 / 1.2.3 
Summary0007400: Call to a member function getReasonPhrase() on null
DescriptionWe are experiencing the following error when the Guzzle object does not contain a response.

Call to a member function getReasonPhrase() on null in [path]/vendor/oxid-solution-catalysts/paypal-client/src/Exception/ApiException.php

This happens because the method is called on the response, although it can be null.
Additional InformationQA -es-
TagsNo tags attached.

Activities

QA

2023-01-18 12:51

administrator   ~0014984

It is as described at the point in the Guzzle Client.
But the reason why the Guzzle client throws an exception is missing.
This is the only way to see why the response = null.

dominik_ziegler

2023-01-18 12:54

reporter   ~0014985

The exact reason is unknown. We had some problems contacting the PayPal API because servers did not respond, so maybe it happens when no connection to the server could be established.

mario_lorenz

2023-01-20 11:38

developer   ~0014986

@dominik_ziegler: thank you for the last comment. One Problem we┬┤ve fixed in this Version is, the reducing of API-Calls by Caching the PayPal-Token. So we reduce the Api-Calls by 50%. Some Merchants with many Requests (maybe you too) have problems with broken or not established connections, because of reaching the API-Call-Limit.
Due to the adjustment, we no longer reach this limit.