View Issue Details

IDProjectCategoryView StatusLast Update
0007385module PayPal Checkoutmodule PayPal checkout - subpublic2023-01-20 16:12
ReporterFATCHIP 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionreopened 
Product Version2.2.0 / 1.2.0 
Target VersionFixed in Version2.2.3 / 1.2.3 
Summary0007385: trick OXID into complete looking order without actual payment via PayPal Checkout
DescriptionHello OXID,
we have encountered two related problems with the PayPal Checkout Module and need your help:

Problems:
1. Create finished Order in OXID via PayPal Checkout without Payment
2. in this case, (see below) one can't switch payments until session end (cl=order&redirected=1).


Greetings
Felix

Steps To ReproduceSteps to reproduce:

1. follow normal checkout and select "PayPal paylater"/"PayPal - sp├Ąter bezahlen" in cl=payment and click "next step".
2. you get redirected to cl=order
3. click "order now" (you get redirected to PayPal Website for Login)
4. use the Browser-back function (gets you back to cl=order)
5. click the "edit" link for Payment, or further use the Browser-back function to get to cl=payment
6. select other Payment (example: PayPal Checkout "credit card")
7. click "next step" (brings you to cl=order, but without credit card form)
8. click "order now" (you get to cl=thankyou and get an order confirmation mail from OXID)
9. in OXID-Admin order exists with stats "OK" and has a paymentdate, (!) so merchants would most likely ship them.
8. Only in the "Paypal Checkout" Tab on the order management you would get a hint because PayPal Checkout Module says that this order wasn't made via Paypal Checkout.


Additional InformationNote:

If you use the "cancel" link on Paypal side:
.../index.php?cl=order&fnc=cancelpaypalsession&token=xxx
you can select another Payment, and if you do in this example, you also get the credit card form.
But this is not always the case.
TagsNo tags attached.

Activities

QA

2022-12-06 14:31

administrator   ~0014931

- es -

The behaviour seems only possible with Pay Later
For PayPal Standard this seems to be caught already, as well as for the other payment methods.

FATCHIP

2022-12-12 10:24

reporter   ~0014941

Is there an ETA for the release of a fix?

[email protected]

2022-12-13 18:24

developer   ~0014948

ready for review

QA

2023-01-11 14:58

administrator  

pp_3.JPG (178,118 bytes)
pp_3.JPG (178,118 bytes)
pp_2.JPG (73,227 bytes)
pp_2.JPG (73,227 bytes)
pp_4.JPG (72,341 bytes)
pp_4.JPG (72,341 bytes)
pp_1.JPG (70,915 bytes)
pp_1.JPG (70,915 bytes)
pp_5.JPG (129,078 bytes)
pp_5.JPG (129,078 bytes)