View Issue Details

IDProjectCategoryView StatusLast Update
0007345module Amazon Paymainpublic2022-09-30 12:00
Reporterosanger 
PrioritynormalSeveritymajorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0007345: Refunds are not booked
DescriptionOn advice from you, I am creating a ticket for our dealer who cannot post refunds.

In the merchant's words:
"The module does not pass "Refund" transactions. The last status written in the DB is "Completed & Captured" so our systems can't work properly and we are behind with the bookings since 22.06."

We have checked how our Instant Payment Notifications (IPNs) are processed by the module. Here a 302 HTTP code comes back and not as expected the code 200.

"providerResponse": "Found",
"dwellTimeMs": 254,
"attempts": 1,
"statusCode": 302

Link: https://github.com/OXID-eSales/amazon-pay-module/blob/d1858b8c2eb4b81791effabc70ee1a004f78c8d9/src/Controller/DispatchController.php#L70-L94

Best regards
Oliver Sänger
Amazon Pay
TagsNo tags attached.

Activities

mario_lorenz

2022-09-29 17:21

developer   ~0014336

@Oliver Sänger: Please checkout our last dev-Branch: "b-6.2.x" (composer require oxid-esales/amazon-pay-module:dev-b-6.2.x). My Collegue (dmitriivolkhinoxid) add a Refund-Method in Order-Backend and fix the behavoir.
If it is Ok, then we will tag this new Version