View Issue Details

IDProjectCategoryView StatusLast Update
0000731OXID eShop (all versions)3.1. Design, GUI, UXpublic2009-09-23 17:47
Reportermarco_steinhaeuser 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version4.0.1.0 revision 15990 
Target VersionFixed in Version 
Summary0000731: Media files: change header before download
DescriptionIn admin area you can add media files to the products; the file format can be everything there even .csv or .jpg.

Downloading this media files from the front end, in case of a .txt or .jpg the file is shown in the same browser window which seems to be not correct.

Change the header information from plain/text to streaming (?) to hand out a download even with txt or jpg files.
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Activities

rimvydas_paskevicius

2009-09-23 17:04

reporter   ~0001812

The esiest solution would be adding .htaccess to media/ folder which forces all files in this folder output with "save as" dialog, but there is problem with Internet Explorer. IE7 does not correctly parses header info and opens files in his own way, so we cant use .htaccess for this task. So file output shoud be implemented in source code.

dainius.bigelis

2009-09-23 17:45

reporter   ~0001814

Handling of different file types from the source code side is quite large change and needs to be considered from different point of views (browsers, server environments, security, black/white lists, etc.). Maybe this can be implemented together with other new features requested in the shop.
So this should be considered in more details. Thus it is moved to customers whishlist and entry here is closed.