View Issue Details

IDProjectCategoryView StatusLast Update
0007249OXID eShop (all versions)2.3. Extensions (modules, themes)public2021-07-01 11:07
Reportermario_lorenz 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.2.0 
Target VersionFixed in VersionPatch for 6.3 
Summary0007249: Admin: Modulsettings: Passwordfields: Validation are broken
Descriptionsince Update of backend jquery (from v1.5.1 to v3.4.1 : OXDEV-2401 OXDEV-2501 Update to latest jquery lib)
the password-validation is broken because of using "attr" instead of "prop" (introduced in jquery v1.6)
Steps To Reproduce* try to fill a password-field
* repeat a wrong password (normally you can't do that)
* save the module-settings
Additional InformationIt will be fixed with this pull-Request:
https://github.com/OXID-eSales/oxideshop_ce/pull/874/

also the style of passwordfields aren ot uniform since the main facelift. It will be fixed with this pull-Request:
https://github.com/OXID-eSales/oxideshop_ce/pull/873/
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined

Activities

QA

2021-06-28 15:15

administrator   ~0013459

Dear Mario Lorenz,

i tried to reproduce this issue in OXID 6.3.0 with Firefox with the Paypal-Plugin.

I couldn't find out what your issue is.

Can you please provide more information.

Thank you

Best Regards

QA - SG -

mario_lorenz

2021-07-01 11:07

developer   ~0013462

@QA: No Problem: The PayPal-Plugin has in the Options the sections "API-Signatur" here you see the "API-Passwort". This is a password-Field defined in the metadata.php. Here you enter two different passwords (usually there is a hint that the passwords are different). Despite the different passwords, you can save the options. And that's wrong.

In OXID 6.1 it works fine,because the OXID-Backend use the old jQuery 1.5.1 In OXID 6.2 the jQuery would be upgraded to v3.4.1. And the functionalities from oxmoduleconfiguration.js does not work anymore.