View Issue Details

IDProjectCategoryView StatusLast Update
0007203OXID eShop (all versions)6. ------ Setup -------public2020-12-22 08:49
Reporterchrys87 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version6.2.3 
Target VersionFixed in Version 
Summary0007203: Installation fails without shell access on the server
DescriptionDear Sir or Madams,

i try to install OXID on an Server just using FTP access. I dont have ssh access on that webspace.
The Setups first page showing the requirements ticks every requrement a green check. so everything should be on place.
Steps To ReproduceWhat i did:
1. create a new Database with user and password (MySQL version MySQL5.6.19 is used by my provider so i turned block_nested_loop=off).
2. download tarballs from downloadpage: https://oxidforge.org/download/download-oxid-eshop-6-2-3-for-php-7-2-7-3?wpdmdl=32735&refresh=5fe07f421fafa1608548162
3. follow https://docs.oxid-esales.com/developer/en/6.1/getting_started/installation/eshop_installation_without_composer.html (special 2. -> without shell access)
4. upload the files to the FTP Server
5. Call setup -> setup starts -> All lights are green
6. follow step by step the setup (country=Germany, language=German, notification for updates = True, install demo shop = True)
7. klick finish -> i wait for several seconds

What happens:
1. a error appears on the screen (500 internal error)
2. the database structure was created
3. when i go to the shop, the maintenance page is shown
Additional InformationShop URL
http://shop.pastaevino-nuernberg.de/

i can reset when you want to try.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP Version7.3
Database VersionMySQL 5.6

Activities

QA

2020-12-21 12:16

administrator   ~0013371

Hello chrys87,

please make sure that your environment meets the system requirements for installing and using the OXID eShop. For further information and a list of the system requirements, please check our Online Documentation: https://docs.oxid-esales.com/developer/en/6.2/getting_started/installation/environment_preparation.html

Kind regards,
Michael

chrys87

2020-12-21 19:14

reporter   ~0013372

The System meets the requirements. Why this ticket is going to be closed? Its not fixed for me.
I checked the documentation, it meets all the requirements, this is confirmed by the first page of the installer. I checked all the needs manualy as well.

QA

2020-12-22 08:49

administrator   ~0013373

Hello chrys87,

I followed the steps, by downloading the tar ball 6.2.3 and sticking to the documentation for the version 6.2. I run through the setup and was able to call the shop frontend and administration area without any errors. So I couldn't reproduce the issue.

You wrote <-- hints
1. a error appears on the screen (500 internal error) <-- Check your PHP error log. The error 500 is a general status which is thrown by the webserver. It means that somewhere in the stack an error happened and the webserver can't show a page because of that. From experience the PHP error log has the information.
3. when i go to the shop, the maintenance page is shown <-- check the source/log/oxideshop.log file for further information. When the shop shows the maintenance site, the framework often logged some more information in the mentioned log file.

To mark an reported issue as a bug, we need detailed information how to reproduce it on a default system.
In this case I recommend you to ask the support team if you have an maintenance contract or the community for support, as this case is likely a configuration issue on the system you try to install the shop. Please also note, that you linked the documentation for the version 6.1 which may be different to 6.2.

Greetings,
Michael