View Issue Details

IDProjectCategoryView StatusLast Update
0007169OXID eShop (all versions)2.1. Master Settingspublic2020-08-25 07:03
Reporterkaistrecker 
PriorityhighSeveritymajorReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0007169: The backend is broken after creating language "en".
DescriptionThe problem is application/controllers/admin/oxadminview.php->_getCountryByCode. This function loads the view "oxv_oxcountry_en" as soon as there is a language with "en" as "Abbreviation". This breaks the backend, because we have to manually create the view after creating the language, but we can't do this, because the backend is broken.

I think there are three solutions for this bug:
1. Automatically create views after creating a new language.
2. Change oxadminview->_getCountryByCode, so it will check if "oxv_oxcountry_en" exists, before loading data from it.
3. Wrap the code in oxadminview->_getCountryByCode in a try-catch.
Steps To Reproduce1. Go to "Master settings" > "Languages".
2. Create a language that has "en" as "Abbreviation".
=> The backend is broken, because it tries to access the view "oxv_oxcountry_en", which does not exist yet.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined

Activities

QA

2020-08-24 12:59

administrator   ~0013277

Dear kaistrecker,

i cannot reproduce this behavoir in the actual version of the Shop (6.2.2). Could you please verify your version?
Nevertheless i would also recommend you to check if some modules changed your backend so some functions are called.
And those function trigger your error.

Best regards

QA - SG -

kaistrecker

2020-08-24 17:05

reporter   ~0013278

Hi,

thanks for the fast reply.

I had this problem in a shop with the version 4.10.8. Also no module changed this part of the backend. So this is a OXID core bug.

I also tested this in one of our 6.2.2 shops. I had no problems there. So this bug does not exist in 6.2.2 anymore.

Best regards,
Kai Strecker

QA

2020-08-25 07:03

administrator   ~0013279

Dear Kai Strecker,

thank you for your feedback.

I closed the bug-report.

Best regards,

QA - SG -