View Issue Details

IDProjectCategoryView StatusLast Update
0007106module PayPal Plusmodule PayPal Plus - subpublic2020-03-26 10:57
ReporterQA 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0007106: order numbers are not transferred to PayPal, although the setting is set in the module
DescriptionWhen an order is placed in OXID eShop Enterprise Edition 6.1.5 with PayPal Plus Extension 3.0.3, the payment goes through, but the order number is not transmitted, although "Transmit the Order No. as "Invoice Number" to PayPal (This can lead to gaps in order numbering)" is enabled in the PayPal Plus settings.
Steps To Reproduce1. Activate PayPal Plus Module
2. Activate in Shop Admin Extensions -> Modules -> PayPal Plus -> Settings -> Other Settings ->
    Transmit the Order No. as "Invoice Number" to PayPal (This can lead to gaps in order numbering)
3. Execute order
4. View PayPal Transaction
Additional InformationOXID EE 6.1.5
PayPal Plus Extension 3.0.3
 - es -
TagsNo tags attached.

Activities

QA

2020-03-10 09:18

administrator  

ppp1.JPG (91,237 bytes)
ppp1.JPG (91,237 bytes)
PPP3.JPG (163,603 bytes)
PPP3.JPG (163,603 bytes)
PPP2.JPG (119,041 bytes)
PPP2.JPG (119,041 bytes)

mario_lorenz

2020-03-23 14:37

developer   ~0013162

Analysis:

When the payment page is called up, a "Paypalplus" payment is created and an invoice number would be generated (setInvoiceNumber).
This method starts a new order session and tries to create a new OrderNr ($oOrder->getNextOrderNr())
The getNextOrderNr method only gets a new number if the method $oOrder->_setNumber() was successful. This in turn is only successful if an update SQL (update oxorder set oxordernr =? Where oxid =?) Was successful.
The SQL cannot be successful at the time because the order is not yet saved in the oxorder.
In OXID4 the method $oDb->execute returned true anyway.
This is no longer the case in OXID6.
That's why there is no OrderNumber anymore ...

Fix is prepared and will be deliver with the next release.

mario_lorenz

2020-03-26 09:59

developer  

payppaypalplus_v3.0.4.zip (3,329 bytes)

mario_lorenz

2020-03-26 09:59

developer   ~0013163

Fix in Version 3.0.4 installable via composer:

composer require oxid-professional-services/paypalplus-module