View Issue Details

IDProjectCategoryView StatusLast Update
0007076OXID eShop (all versions)2.6. Administer orderspublic2020-01-22 07:59
Reportermajd 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version6.2.0-rc.1 
Target VersionFixed in Version 
Summary0007076: currency rate change on update e.g. shipping costs in order_main
Description1)
open backend and set exchange rate for e.g. YEN to 180.10

2)
make order in shopfronend as normal user in YEN (YEN is not your default currency)

3)
open backend and set exchange rate for YEN to 8888.88

4)
open your order in backend and go to order_main

5)
change e.g. shipping costs and click save

6)
SELECT OXCURRATE FROM oxorder WHERE {your order}

RESULT:
8888.88
But it should be 180.10 or why is OXCURRATE a field of table oxorder?

As an idea:
Maybe the value from OXCURRATE should not change on (recalculate -> finalizeOrder -> _loadFromBasket) and (_getOrderBasket),
but there could be an update button in e.g. order_main for the case user explicit wish to update currency rate in an order


TagsNo tags attached.
ThemeMobile
BrowserGoogle Chrome
PHP VersionOther
Database VersionOther

Relationships

duplicate of 0007075 acknowledgedbenjamin.joerger currency rate change on update e.g. shipping costs in order_main 

Activities

QA

2020-01-22 07:59

administrator   ~0013097

-MK