View Issue Details

IDProjectCategoryView StatusLast Update
0007070OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2020-01-07 15:33
ReporterDayanaLuedecke 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version6.1.4 
Target VersionFixed in Version 
Summary0007070: maintained attributes for the article and additionally include them in the Longdesc via the attribute template
DescriptionIf you have maintained attributes for the article and additionally include them in the Longdesc via the attribute template, an error will occur if you have not set a "Description text for meta tags" in the tab as soon as you do something there no longer causes an error.

longdesc:
[{include file = "page / details / inc / attributes.tpl"}]

Additional InformationFehlermeldung:

[2019-12-17 14:03:43] OXID Logger.ERROR: Function 'getAttributes' does not exist or is not accessible! (OxidEsales\Eshop\Application\Controller\FrontendController)
 ["[object] (OxidEsales\\Eshop\\Core\\Exception\\SystemComponentException(code: 0): Function 'getAttributes' does not exist or is not accessible! (OxidEsales\\Eshop\\Application\\Controller\\FrontendController)\n at /home/ebibukce/webseiten/shop/vendor/oxid-esales/oxideshop-ce/source/Core/Base.php:76)\n[stacktrace]\n#0 /home/ebibukce/webseiten/shop/source/tmp/smarty/741a9a249c1bbdcc3d505852ec274b13^%%05^050^05096B0C%%attributes.tpl.php(4): OxidEsales\\EshopCommunity\\Core\\Base->__call('getAttributes', Array)\n#1 /home/ebibukce/webseiten/shop/vendor/smarty/smarty/libs/Smarty.class.php(1876): include('/home/ebibukce/...')\n#2 /home/ebibukce/webseiten/shop/source/tmp/smarty/741a9a249c1bbdcc3d505852ec274b13^%%9E^9E8^9E87ACF6%%ox%3A073c1257cd78c5387e326476fde7b47500.php(29): Smarty->_smarty_include(Array)\n#3 /home/ebibukce/webseiten/shop/vendor/smarty/smarty/libs/Smarty.class.php(1270): include('/home/ebibukce/...')\n#4 /home/ebibukce/webseiten/shop/vendor/oxid-esales/oxideshop-ce/source/Core/UtilsView.php(250): Smarty->fetch('ox:073c1257cd78...')\n#5 /home/ebibukce/webseiten/shop/vendor/oxid-esales/oxideshop-ce/source/Application/Model/Article.php(2545): OxidEsales\\EshopCommunity\\Core\\UtilsView->parseThroughSmarty('<h2><span style...', '073c1257cd78c53...', Object(OxidEsales\\Eshop\\Application\\Controller\\FrontendController), true)\n#6 /home/ebibukce/webseiten/shop/vendor/oxid-esales/oxideshop-ce/source/Application/Controller/ArticleDetailsController.php(327): OxidEsales\\EshopCommunity\\Application\\Model\\Article->getLongDesc()\n#7 /home/ebibukce/webseiten/shop/vendor/oxid-esales/oxideshop-ce/source/Application/Controller/FrontendController.php(1097): OxidEsales\\EshopCommunity\\Application\\Controller\\ArticleDetailsController->_prepareMetaDescription(false)\n#8 /home/ebibukce/webseiten/shop/source/modules/oe/oetags/controllers/oetagsArticleDetailsController.php(237): OxidEsales\\EshopCommunity\\Application\\Controller\\FrontendController->getMetaDescription()\n#9 /home/ebibukce/webseiten/shop/source/tmp/smarty/741a9a249c1bbdcc3d505852ec274b13^%%90^90B^90B7B94A%%base.tpl.php(6): oetagsArticleDetailsController->getMetaDescription()\n#10 /home/ebibukce/webseiten/shop/vendor/smarty/smarty/libs/Smarty.class.php(1876): include('/home/ebibukce/...')\n#11 /home/ebibukce/webseiten/shop/source/tmp/smarty/741a9a249c1bbdcc3d505852ec274b13^%%36^366^366ECF91%%page.tpl.php(125): Smarty->_smarty_include(Array)\n#12 /home/ebibukce/webseiten/shop/vendor/smarty/smarty/libs/Smarty.class.php(1876): include('/home/ebibukce/...')\n#13 /home/ebibukce/webseiten/shop/source/tmp/smarty/741a9a249c1bbdcc3d505852ec274b13^%%08^08A^08ABD53A%%details.tpl.php(14): Smarty->_smarty_include(Array)\n#14 /home/ebibukce/webseiten/shop/vendor/smarty/smarty/libs/Smarty.class.php(1270): include('/home/ebibukce/...')\n#15 /home/ebibukce/webseiten/shop/vendor/oxid-esales/oxideshop-ce/source/Core/ShopControl.php(488): Smarty->fetch('page/details/de...', 'ox|0|0|0|0|ssl|...')\n#16 /home/ebibukce/webseiten/shop/vendor/oxid-esales/oxideshop-ce/source/Core/ShopControl.php(344): OxidEsales\\EshopCommunity\\Core\\ShopControl->_render(Object(oetagsArticleDetailsController))\n#17 /home/ebibukce/webseiten/shop/vendor/oxid-esales/oxideshop-ce/source/Core/ShopControl.php(276): OxidEsales\\EshopCommunity\\Core\\ShopControl->formOutput(Object(oetagsArticleDetailsController))\n#18 /home/ebibukce/webseiten/shop/vendor/oxid-esales/oxideshop-ce/source/Core/ShopControl.php(137): OxidEsales\\EshopCommunity\\Core\\ShopControl->_process('OxidEsales\\\\Esho...', NULL, NULL, NULL)\n#19 /home/ebibukce/webseiten/shop/vendor/oxid-esales/oxideshop-ce/source/Core/Oxid.php(26): OxidEsales\\EshopCommunity\\Core\\ShopControl->start()\n#20 /home/ebibukce/webseiten/shop/source/index.php(15): OxidEsales\\EshopCommunity\\Core\\Oxid::run()\n#21 /home/ebibukce/webseiten/shop/source/oxseo.php(28): require('/home/ebibukce/...')\n#22 {main}\n"] []
TagsException
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined

Activities

QA

2020-01-07 15:33

administrator   ~0013086

Hey DayanaLuedecke,

thank you for reporting that behavior.
The reason for the "function not found" message is the context in which the function is called. When you have a look at the template "page/details/inc/attributes.tpl" you will see that it calls the function getAttributes by the variable name "$oView". But the long description is called in the context of the variable name "$oDetailsProduct". If you call the template this way: [{include file="page/details/inc/attributes.tpl" oView=$oDetailsProduct}] then the error is gone, although the list will be empty because this object has not yet loaded the attribute list.

I close the entry, as it is not an error in itself. Changing the order in which or where the templates are included will probably require some custom changes.

-MK