View Issue Details

IDProjectCategoryView StatusLast Update
0006999OXID eShop (all versions)4.01. Database handlingpublic2019-11-12 08:54
Reporterpvanhemmen 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.0.0 
Target VersionFixed in Version6.2.0-rc.1 
Summary0006999: oxadminlog adodb extension not ported to PDO / OXID 6
DescriptionIn shop Versions prior to v6 logging of sql queries was done through the adodb extension oxadminlog. With the introduction of PDO this feature is gone, although all references in code like the setting blLogChangesInAdmin are still there. Since this has been a useful feature and i can find no deprecation entries whatsoever that this was going to be removed it seems like this feature was unintentionally forgotten in v6.
Steps To ReproduceTry to log something to oxadminlog
Additional InformationPlease bring back this feature (preferred solution) or otherwise remove references to it as well as the corresponding table.
TagsAdmin, Database, Log, SQL
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Activities

QA

2019-06-25 14:08

administrator   ~0012923

-MK