View Issue Details

IDProjectCategoryView StatusLast Update
0006993OXID eShop (all versions)2.4. Administer productspublic2019-11-12 08:58
Reporterpbenke 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.1.1 
Target VersionFixed in Version6.2.0-rc.1 
Summary0006993: Wrong format in external url on article input
DescriptionFor example:
Stored value in database in oxarticles.OXEXTURL: https://www.google.com
The form will show http://https://www.google.com

Reason:
source/Application/views/admin/tpl/article_extend.tpl

=> line 133
input ... name="editval[oxarticles__oxexturl]" value="http://[{$edit->oxarticles__oxexturl->value}]"...
(Look at value)
Steps To ReproduceInput an article with an external url (tab "Erweitert")
TagsAdmin Template, Article
ThemeNot defined
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Activities

QA

2019-06-12 13:23

administrator   ~0012913

Last edited: 2019-06-12 13:24

View 3 revisions

Thanks for your report. I agree that the form is showing a wrong URL since it always adds "http://" to the beginning, but unlike your description I don't run in any issue with that behavior present.

I did the following:
1) Chose an article.
Extern URL form field shows "http://".
Database field shows "".
2) Filled in the url https://www.myexternurl.de
3) Saved.
Extern URL form field shows: "http://https://www.myexternurl.de/".
Database field shows "https://www.myexternurl.de/".
4) Saved again.
Extern URL form field still shows: "http://https://www.myexternurl.de/".
Database field still shows "https://www.myexternurl.de/".

Therefore the form doesn't look good, but the behavior have not led into a problem with the saved value. The URL is stored correctly in the database even after resaving. As a result I have acknowledge your issue as a bug because the form shows a wrong value. But since the mechanism isn't affected, I've edited the issue description and set the priority to low.

[sp]

pbenke

2019-06-12 13:36

reporter   ~0012914

Thanky you,
sorry, I reported not everything.

The error occurs in Frontend!

Please have a look inside the wrong template:
source/Application/views/flow/tpl/page/details/inc/tabs.tpl
Line 12

Thank you.

QA

2019-06-12 14:43

administrator   ~0012915

Please specify your concern. The link in the shop frontend works fine in my testing environment.

[sp]

pbenke

2019-06-12 15:00

reporter   ~0012916

Sorry, my fault.
Has been already fixed in the last Flow theme version.

Thank you.