View Issue Details

IDProjectCategoryView StatusLast Update
0006940OXID eShop (all versions)2.4. Administer productspublic2019-01-14 15:41
Reporteravalue 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version6.1.1 
Target VersionFixed in Version 
Summary0006940: SEO Url can only be changed for main category
DescriptionThe method _getCategory of class SeoEncoderArticle checks instances of FrontendController, where OXID 5 checks for oxUBase / oxView. Thus the method is used in backend too, it should check for Base Class.

Steps To Reproduce1. Navigate to any product in backend
2. Assign at least 2 categories
3. Set X as main category
4. Switch to the non-main-category in SEO tab
5. Try to update SEO URL for that category
6. The URL will be the same
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP Version7.1
MySQL VersionNot defined

Relationships

related to 0005267 resolvedLinas Kukulskis Bug in Article SEO-Tab 

Activities

QA

2019-01-14 15:34

administrator   ~0012760

Last edited: 2019-01-14 15:34

View 2 revisions

reproduced in 6.1.1
-MK

QA

2019-01-14 15:41

administrator   ~0012761

No change required since it was lately already changed: https://github.com/OXID-eSales/oxideshop_ce/commit/832ec8bdb2cc97d91638e190cd16c8fcf718495b#diff-aabe0f1c3fe9c3570f5c1910d52ca45eL233