View Issue Details

IDProjectCategoryView StatusLast Update
0006902OXID eShop (all versions)1.02. Price calculations (discounts, coupons, additional costs etc.)public2018-09-17 12:49
ReporterJCT 
PriorityurgentSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.1.0 
Target VersionFixed in Version6.1.1 
Summary0006902: Product detail page logged in user – wrong return value FrontendController.isVatIncluded()
DescriptionIf an registered user is logged in without UStID, the FrontendController returns the wrong value for VAT included.
This is due to a type mismatch in PHP.
The if statement has a explicit type comparison to null, the given value from the database is an empty string ''. (Line: 2952 | Application/Controller/FrontendController.php)
Steps To Reproduce1. Register a new user with account and leave the UStID fields empty.
2. Login as the new registered user
3. Open a product detail page
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Activities

JCT

2018-09-13 13:52

reporter   ~0012625

PR: https://github.com/OXID-eSales/oxideshop_ce/pull/666

QA

2018-09-13 15:30

administrator   ~0012626

With a new created user the prices have no * mark anymore after login.