View Issue Details

IDProjectCategoryView StatusLast Update
0006782OXID eShop (all versions)6. ------ Setup -------public2018-03-13 09:41
Reporterflorian1996 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.0.0 
Target VersionFixed in Version6.0.2 
Summary0006782: install EE Version 6.0.0 failed
DescriptionI tried with the command "composer create-project oxid-esales/oxideshop-project V6 dev-b-6.0-ee
" to install OXID EE Version 6.0.0.

But there comes the following error: "Script if [ -f ./vendor/bin/oe-eshop-ide_helper ]; then oe-eshop-ide_helper; fi handling the oe:ide-helper:generate event returned with error code 255".

and then comes in the setup of "directories and login" this error:
Error while executing the command 'Migration'.Returncode' 0 ' (the whole error is in the appendix)
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP Version5.6
MySQL VersionNot defined

Activities

florian1996

2018-01-31 18:29

reporter  

QA

2018-02-01 09:35

administrator   ~0012374

I tried your command on a machine running PHP 5.6 and didn't face any of the errors. Composer ended without any error and also the shop setup finished correct. Shop is working.

Can't acknowledged the issue as a bug, because I'm unable to reproduce it. I'm pretty sure the problem comes from your system and has nothing to do with the OXID eShop 6.0.

gregor.hyneck

2018-03-13 09:07

administrator   ~0012416

This issue was reproduced with these settings in the my.cnf-configuration file:

[mysqld]
collation-server = utf8_unicode_ci
character-set-server = utf8

This is a bug in Doctrine migrations.

gregor.hyneck

2018-03-13 09:30

administrator   ~0012419

Fixed with https://github.com/OXID-eSales/oxideshop-doctrine-migration-wrapper/tree/v2.1.1