View Issue Details

IDProjectCategoryView StatusLast Update
0000675OXID eShop (all versions)2. ----- eShop backend (admin) -----public2009-09-21 10:30
ReporterSpritje 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.0.1.0 revision 15990 
Target VersionFixed in Version4.1.6 revision 22740 
Summary0000675: Statistics show JpGraph error instead of own error messages (only PE)
DescriptionHave at least one order processed in the shop. Then go to Statistic => Stats & Log-Maint. Click "Generate Report". In the opened page in the section "Shop per Week" there is error message generated by JPGraph (see attachment).

The error message should be properly handled and own shop message should be displayed.
Additional InformationImplement additional check - if the data needed for reports is available or not. If data is missing - do not allow generating report at all. In this case just write the messages:
"The statistic could not be generated because not enough data is available"
"Die Statistik konnte nicht erstellt werden, weil nicht genĂ¼gend Daten vorhanden sind"
TagsNo tags attached.
Theme
BrowserAll
PHP Version5.2.6
Database Version5.0.33

Relationships

related to 0001220 resolvedarvydas_vapsva display of statistics is not correct for search words etc. 

Activities

2009-03-09 15:52

 

JpGraphError.png (2,729 bytes)
JpGraphError.png (2,729 bytes)

arvydas_vapsva

2009-09-21 10:29

reporter   ~0001796

fixed