View Issue Details

IDProjectCategoryView StatusLast Update
0006718OXID eShop (all versions)6. ------ Setup -------public2017-11-06 10:52
Reporterlins 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformWindowsOSWindows OS Version10
Product Version6.0.0-rc.3 
Target VersionFixed in Version 
Summary0006718: Error while installing RC3 - oe:ide-helper:generate event returned with error code 1
DescriptionHey guys,

some error is thrown on my machine while installing RC3:

C:\development\webroot\my-shop>composer create-project --no-dev oxid-esales/oxideshop-project my-shop dev-b-6.0-ce
Installing oxid-esales/oxideshop-project (dev-b-6.0-ce 2d92aa765cdb6b9fe803568cce25de0bbdf9d7d0)
  - Installing oxid-esales/oxideshop-project (dev-b-6.0-ce b-6.0-ce): Cloning b-6.0-ce from cache
Created project in my-shop
Loading composer repositories with package information
Updating dependencies
Package operations: 48 installs, 0 updates, 0 removals
  - Installing zendframework/zend-eventmanager (3.2.0): Downloading (100%)
  - Installing zendframework/zend-code (2.6.3): Downloading (100%)
  - Installing webmozart/assert (1.2.0): Loading from cache
  - Installing webmozart/path-util (2.3.0): Downloading (100%)
  - Installing webmozart/glob (4.1.0): Downloading (100%)
  - Installing symfony/yaml (v2.8.28): Downloading (100%)
  - Installing symfony/process (v2.8.28): Downloading (100%)
  - Installing symfony/polyfill-mbstring (v1.6.0): Loading from cache
  - Installing symfony/finder (v2.8.28): Downloading (100%)
  - Installing symfony/filesystem (v3.3.10): Loading from cache
  - Installing psr/log (1.0.2): Loading from cache
  - Installing symfony/debug (v3.0.9): Loading from cache
  - Installing symfony/console (v2.8.28): Downloading (100%)
  - Installing smarty/smarty (v2.6.30): Downloading (100%)
  - Installing seld/phar-utils (1.0.1): Downloading (100%)
  - Installing seld/jsonlint (1.6.1): Downloading (100%)
  - Installing seld/cli-prompt (1.0.3): Downloading (100%)
  - Installing phpmailer/phpmailer (v5.2.25): Downloading (100%)
  - Installing payone-gmbh/oxid-6 (1.0.3): Downloading (100%)
  - Installing oxid-esales/paypal-module (v5.1.1): Downloading (100%)
  - Installing oxid-esales/paymorrow-module (v2.0.0): Downloading (100%)
  - Installing justinrainbow/json-schema (5.2.6): Downloading (100%)
  - Installing composer/spdx-licenses (1.1.6): Downloading (100%)
  - Installing composer/semver (1.4.2): Downloading (100%)
  - Installing composer/ca-bundle (1.0.8): Downloading (100%)
  - Installing composer/composer (1.5.2): Downloading (100%)
  - Installing oxid-esales/oxideshop-facts (v2.1.0): Downloading (100%)
  - Installing oxid-esales/oxideshop-unified-namespace-generator (v1.0.0-beta.4): Downloading (100%)
  - Installing ocramius/proxy-manager (1.0.2): Downloading (100%)
  - Installing doctrine/lexer (v1.0.1): Loading from cache
  - Installing doctrine/inflector (v1.1.0): Loading from cache
  - Installing doctrine/collections (v1.4.0): Loading from cache
  - Installing doctrine/cache (v1.6.2): Loading from cache
  - Installing doctrine/annotations (v1.4.0): Loading from cache
  - Installing doctrine/common (v2.7.3): Loading from cache
  - Installing doctrine/dbal (v2.5.12): Loading from cache
  - Installing doctrine/migrations (v1.5.0): Downloading (100%)
  - Installing oxid-esales/oxideshop-doctrine-migration-wrapper (v2.1.0): Downloading (100%)
  - Installing oxid-esales/oxideshop-demodata-installer (v1.1.1): Downloading (100%)
  - Installing oxid-esales/oxideshop-demodata-ce (v6.0.0-rc.3): Downloading (100%)
  - Installing oxid-esales/oxideshop-db-views-generator (v1.1.1): Downloading (100%)
  - Installing oxid-esales/oxideshop-composer-plugin (v2.0.1): Downloading (100%)
  - Installing oxid-esales/eshop-facts (v1.0.2): Downloading (100%)
  - Installing oxid-esales/eshop-edition-facts (v1.0.0): Downloading (100%)
  - Installing oxid-esales/flow-theme (v2.3.1): Downloading (100%)
  - Installing oxid-esales/oxideshop-ce (v6.0.0-rc.3): Downloading (100%)
  - Installing ddoe/wysiwyg-editor-module (v1.0.0): Downloading (100%)
  - Installing oxid-esales/oxideshop-metapackage-ce (v6.0.0-rc.3): Downloading (100%)
Writing lock file
Generating autoload files
Generating OXID eShop unified namespace classes ... Done
Copying module payone-gmbh/oxid-6 files...
Copying module oxid-esales/paypal-module files...
Copying module oxid-esales/paymorrow-module files...
Copying theme oxid-esales/flow-theme files...
Installing shop package.
Copying shop files to source directory...
Copying module ddoe/wysiwyg-editor-module files...
Class Incenteev\ParameterHandler\ScriptHandler is not autoloadable, can not call post-update-cmd script
> if [ -f ./vendor/bin/oe-eshop-ide_helper ]; then oe-eshop-ide_helper; fi
Script if [ -f ./vendor/bin/oe-eshop-ide_helper ]; then oe-eshop-ide_helper; fi handling the oe:ide-helper:generate event returned with error code 1


ENV:

Windows 10 64bit
Composer version 1.4.1 php
PHP 7.1.8 (cli) (built: Aug 1 2017 21:10:46) ( ZTS MSVC14 (Visual C++ 2015) x86 )


Github issue:
https://github.com/OXID-eSales/oxideshop_project/issues/1
Steps To ReproduceRunning "composer create-project --no-dev oxid-esales/oxideshop-project app dev-b-6.0-ce" via CLI.
Additional InformationENV:

Windows 10 64bit
Composer version 1.4.1 php
PHP 7.1.8 (cli) (built: Aug 1 2017 21:10:46) ( ZTS MSVC14 (Visual C++ 2015) x86 )
TagsComposer
ThemeNot defined
BrowserNot defined
PHP VersionOther
MySQL VersionAll

Relationships

duplicate of 0006633 confirmedvilma_liorensaityte Errot during installation via composer 

Activities

There are no notes attached to this issue.