View Issue Details

IDProjectCategoryView StatusLast Update
0006711OXID eShop (all versions)2.3. Extensions (modules, themes)public2017-11-30 10:54
ReporterHR 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.0.0-rc.3 
Target Version6.0.0-rc.3Fixed in Version6.0.0 
Summary0006711: admin/oxajax.php needs to handle module namespaced ajax container classes
DescriptionSeems like admin/oxajax.php still relies on the BC classes. The ajax container class is expected to be controller key . '_ajax'. What needs to be added here is resolving controller key (usually the old BC class name) to a namespace.

Current version works fine as long as no namespace module tries to use its own admin ajax popup drag and drop. Issue appears with the b2b/Offers submodule when fully ported to namespaces.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Relationships

duplicate of 0006668 resolvedrobert blank in source/admin/oxajax.php ControllerClassNameResolver is not used for resolving container. Can't create custom drag&drop in mod 

Activities

HR

2017-10-18 10:37

manager   ~0012244

This needs to be resolved best before 6.0 release and has to be resolve dbefore B2B fully ported to namespaces version is released.

robert blank

2017-11-14 10:57

manager   ~0012266

This bug was resolved with this commit:
https://github.com/OXID-eSales/oxideshop_ce/commit/63788d285e5dc411c91f9fe05d2177368049da42