View Issue Details

IDProjectCategoryView StatusLast Update
0006704OXID eShop (all versions)2.2. Shop settingspublic2017-12-12 14:28
Reportereike_spriess 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.10.6 / 5.3.6 
Target VersionFixed in Version6.0.0 
Summary0006704: If RDFa is activated in EE the product details page can no longer be reached
DescriptionIf the integration of RDFa is activated in the Enterprise Edition Version 5.3.5 via backend under Master settings -> Core settings - RDFa -> Global configuration, the product details page can no longer be reached.

OXID complains according to Exception Log that the method getBundleArticle is missing.
This method is called in the template application/views/flow/tpl/rdfa/details/inc/object. tpl.
This method exists in the OXID editions CE and PE, but does not exist in the oxid edition EE.
Steps To Reproduce1. Activate RDFa via Backend (Demoshop EE)
   Master settings -> Core settings - RDFa -> Global configuration
2. Call product details page

http://demoshop.oxid-esales.com/EnEd/index.php?cl=start&redirected=1
Additional InformationIn CE / PE application/controller/details.php::getBundleArticle()
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Activities

vilma_liorensaityte

2017-12-12 10:28

administrator   ~0012316

Works fine since OXID eShop 6.0 version.

QA

2017-12-12 14:28

administrator   ~0012318

in template application/views/flow/tpl/rdfa/details/inc/object. tpl
the following lines must be deleted:

[{if $o $oView->getBundleArticle ()}]
    [{assign var="oBundleProduct" value=$oView->getBundleArticle ()})
    <div rel="gr: includes" resource="[{$oBundleProduct->getLink ()}]#productdata"></div>
[/{/if}]