View Issue Details

IDProjectCategoryView StatusLast Update
0006645OXID eShop (all versions)4.06. Language and translationspublic2017-06-01 10:51
Reporteredip 
PriorityimmediateSeveritycriticalReproducibilityalways
Status resolvedResolutionfixed 
Product Version6.0.0-rc.1 
Target VersionFixed in Version6.0.0-rc.2 
Summary0006645: Wrong language encoding in modulegenerator
DescriptionThe german language file in the modulegenerator is encoded in ISO-8859-1. As Oxid 6 only supports UTF-8, this leads to problems when caching these language strings. The problem is caused because the recoding was removed in the method _getLanguageFileData of the Language-Class.
As a consequence of this language strings of a 3rd party module are not loaded completely.
Steps To ReproduceInstall a 3rd party module with admin language files in german (e.g. digidesk evoSlider).
Additional InformationSolution: Change modules/oxps/modulegenerator/views/admin/de/oxpsmodulegenerator_admin_de_lang.php to UTF-8
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined