View Issue Details

IDProjectCategoryView StatusLast Update
0006601OXID eShop (all versions)4.12. Subshop handlingpublic2017-03-08 14:54
Reporter[email protected] 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionopen 
PlatformLinuxOSRHELOS Version6
Product Version4.10.3 / 5.3.3 
Target VersionFixed in Version 
Summary0006601: Cross Domain Problem with wrong SSL Url in Visual CMS Module
DescriptionIn a multishop environment when you use the Visual CMS Module you wouldn't see any icons from font awesome because you receive a crossdomain error due to an invalid url.
Steps To Reproduce1. Setup a Multishop environment
2. Activate Visual CMS Module
3. Base URL for the admin is for example https://www.foo.de
4. Switch in backend to the subshop (which has a configured URL https://www.bar.de
5. Your Browser is still https://www.foo.de/admin/....
6. Go to the Visual CMS content management
7. You see no icons because the css files have the url (https://www.bar.de) from the subshop but you are still on https://www.foo.de/admin
Additional InformationThe error seems to be because the function getModuleUrl() in the oxviewconfig.php is using the method $this->getConfig()->getCurrentShopUrl(false); with the default parameter false. So the method is never returning the SSL Url for the backend if configured in the config.inc.php file. Instead it's always returning the URL for the current selected subshop. The default parameter false makes here no sense since there is another check for the admin mode in the method itself. So the correct URL should be returned anyway.
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Version5.6
MySQL Version5.6

Relationships

duplicate of 0006474 resolvedanton.fedurtsya Icons of Visual Editor and other custom moduls not shown in backend (subshop) 

Activities

QA

2017-03-08 14:54

administrator   ~0011991

duplicate of 0006474