View Issue Details

IDProjectCategoryView StatusLast Update
0006589OXID eShop (all versions)2.2. Shop settingspublic2024-04-03 10:51
Reporterjustmike Assigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
OSLINUX 
Product Version4.9.1 / 5.2.1 
Summary0006589: blVatIdCheckDisabled has no effect
DescriptionNo matter if you set blVatIdCheckDisabled to true or false, the VatId is validated in any case.
Steps To Reproduce- set blVatIdCheckDisabled to FALSE
- register new user with an invalid vat id
- the VatId gets validated and reported as invalid -> works as expected

- set blVatIdCheckDisabled to TRUE
- register new user with an invalid vat id
- the VatId gets validated and reported as invalid -> one would expect NO validation of the VatID in this case
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
Database VersionNot defined

Relationships

related to 0006044 closedflorian.auer UST ID check is always enabled 

Activities

QA

2017-02-14 13:40

administrator   ~0011975

Last edited: 2017-02-14 13:42

Reproducible in Demoshop. Current demoshop version is PE4.10.3

Sven Brunk

2024-04-03 10:51

administrator   ~0016700

I agree that the setting has a misleading name, but the setting only affects the ONLINE check. The offline check that verifies the IDs conform to the format (using the included checksum numbers of the standard) is always on.
This is by design.
If you have a valid use case that goes beyond the pure expectation based on the setting name, please reopen the ticket with a detailed description.