View Issue Details

IDProjectCategoryView StatusLast Update
0006586OXID eShop (all versions)4.01. Database handlingpublic2024-04-03 10:46
ReporterPaulius.Kupetis Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.10.2 / 5.3.2 
Fixed in Version6.0.0-rc.2 
Summary0006586: \oxBase::_update always returns true
Description\oxBase::_update always returns true.
transforming object to boolean always gives true.

ALSO in V6 shop this is partly fixed - execute returns number, so 0 can be transformed to false other numbers to true.

BUT what this function intends to return?

Maybe it would be better to return if sql was successful or not.
not just if sql affected queries..

This affects some modules like ERP.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionAll
Database VersionAll

Activities

anton.fedurtsya

2018-07-27 16:13

administrator   ~0012543

Hello, looks like issue is fixed on 2017-03-28, now its eather true on success or DatabaseException on sql error.

Sven Brunk

2024-04-03 10:46

administrator   ~0016699

Fixed in https://github.com/OXID-eSales/oxideshop_ce/commit/64feb9e108798a0e6bc8566e00985818df1a17f9