View Issue Details

IDProjectCategoryView StatusLast Update
0006522OXID eShop (all versions)1.10. RSSpublic2018-10-10 12:52
Reporterdfu 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
Product Version4.10.1 / 5.3.1 
Target VersionFixed in Version6.1.1 
Summary0006522: Wrong price-calculation for variants in RSS-feed
DescriptionIf you set an parent article price (so with variants) to 0.00, the price-calculation fails and throws something like "jeans ab 0,00".
Instead of taking varMinPrice, the price is taken.

The price of the parent article (specially if not buyable) shouldn't be considered as a price.
Steps To Reproduce- Navigate to the demoshop / install a new shop
- Install demo-data
- Set price of the Anna-Jeans article to 0,00
- Watch "newest articles" rss feed

The price of the unbuyable parent article is display instead of the min price of the variants
TagsSolution Provided
ThemeAzure, Flow
BrowserNot defined, Firefox, Internet Explorer, Google Chrome, Apple Safari
PHP VersionAll
MySQL VersionAll

Activities

dfu

2016-10-11 15:51

reporter   ~0011832

https://github.com/OXID-eSales/oxideshop_ce/pull/498

QA

2016-10-12 10:28

administrator   ~0011833

if in shop admin -> master settings -> core settings -> system -> Parent" Products can be purchased is checked and the price of the parent article is set to 0 EUR the varMinPrice is set to 0 EUR.

If option is not checked the varMinPrice is set to the lowest variant price.

So everything works fine. Nothing has to be changed.
Bug will be closed.

marco_steinhaeuser

2016-10-12 11:16

administrator   ~0011835

It turned out that the issue was misunderstood, that's why this bug will be re-opened again.

> "If option is not checked the varMinPrice is set to the lowest variant price."

This is not true. In RSS feed getPrice is used instead of getVarMinPrice. So the issue is clearly about the RSS feed, not the regular page view.

anton.fedurtsya

2018-10-10 12:52

manager   ~0012636

Fixed with mentioned pull request.