View Issue Details

IDProjectCategoryView StatusLast Update
0006516OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2018-05-11 10:28
Reporterkeywan.ghadami 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionreopened 
Product Version 
Target VersionFixed in Version6.0.3 
Summary0006516: When a country has the option "Do not bill VAT only if provided valid VAT I", the shop shows "* incl. VAT, plus shipping" anyway
DescriptionA customer registers with a country, which has the option "Do not bill VAT only if provided valid VAT ID". But the shops displays still "* incl. VAT, plus shipping" in the footer.

The shop has to display "exclusive shipping" instead of "incl. VAT", because there is no VAT and the shipping isn't in the article price included.
Steps To Reproduce1. goto admin
2. activate a county, set the option "Do not bill VAT only if provided valid VAT ID" to true.
3. goto frontend
4. register a new customer with the land from step 2. with a valid vatid
5. have a look to the footer, the shop will still display "* incl. VAT, plus shipping", because the method oxUBase::isVatIncluded() doesn't check the vatid /vatidstatus of that user and therefore not if the user doesn't need to pay the VAT.
TagsSolution Provided
ThemeNot defined
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Relationships

related to 0005384 acknowledged When a country has the option "Do not bill VAT", the shop shows "* incl. VAT, plus shipping" anyway 

Activities

There are no notes attached to this issue.