View Issue Details

IDProjectCategoryView StatusLast Update
0006489OXID eShop (all versions)2.3. Extensions (modules, themes)public2016-08-23 10:20
ReporterProclane Commerce GmbH 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformLinux OSDebianOS Version8.5
Product Version4.10.1 / 5.3.1 
Target VersionFixed in Version 
Summary0006489: Modules brokes when class extending-definition is not identical to other modules
DescriptionWhen Module-Keys in every module in extend-Block are not identical written so it happens that the module overloading not work.
Steps To Reproduce- create one module with CamelCase overloading definitions like:

'extend' => [
'Basket' => 'c4s/c4s_core/application/controllers/c4s_core_basket',
]

- create one module with lowercase overloading definition like:

'extend' => array( //Ɯberladung von OXID-Controllern
       
        'basket' => 'c4s/c4s_ordercreate/application/controllers/c4s_ordercreate_basket',
),


- write (at example) following sourcecode into c4s_core_basket:
class c4s_core_basket extends c4s_core_basket_parent{

    public function render() {
        $oConfig = $this->getConfig();
        $oBasket = $oConfig->getSession()->getBasket();
        $oBasket->setDeliveryAddressId("10");
        var_dump($oBasket);
        return parent::render();
    }


render-Method of c4s_core_basket will never called on execution of basket-Controller.
Additional Informationsome modules from companies aren't encrypted with zend guard loader or anything else, so it is not possible to change the definition of extended classes. When the Definition is not identical it is not easy to change it. Also when two or more external modules has another definition and are encrypted it is still problematic.
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP Version5.6
Database Version5.5

Relationships

duplicate of 0005687 assignedDariush Ghiass-Fakhri Module chain is case sensitive 

Activities

Proclane Commerce GmbH

2016-08-23 10:02

reporter  

oxid_module_bug.PNG (23,238 bytes)
oxid_module_bug.PNG (23,238 bytes)

QA

2016-08-23 10:20

administrator   ~0011751

Last edited: 2016-08-23 10:20

View 2 revisions

This is a duplicate of 0005687 so this is closed.