View Issue Details

IDProjectCategoryView StatusLast Update
0006411OXID eShop (all versions)4.11. Image handlingpublic2017-02-02 15:12
Reporters.krenz 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.10.4 / 5.3.4 
Summary0006411: Image generation for URLs containing a double slash fails.
DescriptionIf the URL for a generated picture includes a double slash right after the "out/pictures" part, oxDynImgGenerator::getInstance()->outputImage() will send an empty file. This happens because the method oxDynImgGenerator::_getImageUri() checks for the existance of "out/pictures/generated" but it will get "out/pictures//generated" in that case. So the check fails and the image won't be generated.

For example:
URL: http://whatever.domain/out/pictures//generated/product/1/247_200_75/lf_s4_1.jpg
If the image isn't generated --> Image generation fails
If the image already exists --> anything is fine (the filesystem ignores the second slash, but OXID doesn't)


TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Activities

s.krenz

2016-06-14 11:46

reporter   ~0011645

Last edited: 2016-06-14 12:04

View 2 revisions

I created a fix (including test) and a pull request on GitHub: https://github.com/OXID-eSales/oxideshop_ce/pull/406

gregor.hyneck

2017-02-02 15:08

administrator   ~0011954

Bug was fixed with PR 0000406 which was merged with commits
https://github.com/OXID-eSales/oxideshop_ce/commit/15dac8bffd1ce075045f2839d3ef0b7663c97023
and backported to 5.3