View Issue Details

IDProjectCategoryView StatusLast Update
0006399OXID eShop (all versions)2.6. Administer orderspublic2016-05-27 07:58
ReporterAlban 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformChromeOSMac OS XOS Version10.11.5
Product Version4.9.8 / 5.2.8 
Target VersionFixed in Version 
Summary0006399: Updating or adding articles to order in admin changes all item prices to current article prices
DescriptionWhen updating an order in the admin backend, for example by adding a new item, storno of an item or just by clicking "Aktualisieren", the whole order is recalculated and the current article price is taken for every item in the order, not the original item price at the time when the order was placed (which is stored in the oxorderarticle).
I think the original prices the customer ordered by should be kept, the new prices should only be applied to newly added items.
Steps To ReproduceGo to admin->Orders, select an Order go to tab Articles.
Choose Add Article, add one.
Go to Articles, change the price of the Article.
Go back to orders, add the same article again. The price of the newly added article and the article already in the order are changed.
TagsAdmin, Calculations, Order Recalculation
ThemeNot defined
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Relationships

duplicate of 0004624 acknowledged Order recalculation does not use discounts/taxes which were valid when order was made, but current ones 

Activities

QA

2016-05-27 07:57

administrator   ~0011605

Closed as duplicate of 0004624