View Issue Details

IDProjectCategoryView StatusLast Update
0006376OXID eShop (all versions)4.08. Cachepublic2016-09-30 11:57
Reporterkeywan.ghadami 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version4.10.2 / 5.3.2 
Summary0006376: Admin backend clear not enabled content cache (EE)
Descriptionin admin backend mode the shop clears the content cache even if that is disabled


Steps To Reproducedisable content cache,
save something in admin backend
watch database queries
you should see that delete from oxcache is executed
Additional Informationit does not seam to have an high impact deleting an not active cache but together with other related issues this issue causes performance problems because it is executed to often.

see Base.php(6.x) or oxbase.php (5.x) and look for

function _resetCache

$cache->reset();

suggested solution is to add an condition in oxcache->reset method that checks if the content cache is enabled
 


TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Activities

keywan.ghadami

2016-04-16 17:32

developer   ~0011534

created an pull request with my suggested solution
https://github.com/OXID-eSales/oxideshop_ee/pull/8