View Issue Details

IDProjectCategoryView StatusLast Update
0006302OXID eShop (all versions)1.10. RSSpublic2016-04-27 09:41
ReporterAlexN 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOS Version
Product Version4.9.4 / 5.2.4 
Target VersionFixed in Version4.9.8 / 5.2.8 
Summary0006302: Changes in action "oxnewest" are shown on the start page but not in the RSS feed
DescriptionWhen adding/removing articles from the action "oxnewest" the changes are displayed correctly on the start page of the shop at once. However the contents of the RSS feed are not updated unless the tmp directory is cleared.
Expected behaviour: Changes in the article-assignments are shown on the start page and in the RSS feed at once.
Steps To Reproduce1. Install OXID 4.9.4
2. Change article-assignments in action oxnewest
3. Open rss-feed for newest articles.
> No changes
4. Clear temp dir
5. Open rss-feed for newest articles.
> changes
Additional InformationThis occurs in OXID 4.9.5 as well while in 4.9.3 I couldn't reproduce it.
TagsNo tags attached.
ThemeAzure
BrowserFirefox
PHP Version5.3
MySQL VersionNot defined

Activities

QA

2015-12-31 16:35

administrator   ~0011397

Last edited: 2015-12-31 16:36

View 2 revisions

Reproduced in current PE demoshop (4.9.6).
Workaround is already described: clear tmp dir

Maybe it is related to the changes introduced in 4.9.3? https://github.com/OXID-eSales/oxideshop_ce/blame/v4.9.3/source/application/controllers/admin/oxadminview.php#L427
But that would mean the behaviour should be different with versions <= 4.9.2 and not with 4.9.3 as mentioned by the reporter.
Anyways it might be related to 0006302 or more probably to 0005825.

saulius.stasiukaitis

2016-04-27 09:41

reporter   ~0011552

To find changes check for commits with comment ESDEV-6302 and 006302.