View Issue Details

IDProjectCategoryView StatusLast Update
0006291OXID eShop (all versions)1.01. Products (product, categories, manufacturer, promotions etc.)public2016-09-30 16:42
Reporterleofonic 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.6 / 5.2.6 
Target VersionFixed in Version4.10.2 / 5.3.2 
Summary0006291: nopic.jpg generation fails if image is not a jpg
DescriptionIf a nonexistant image is requested and there is no nopic.jpg in the particular "generated" folder, a resized copy of nopic.jpg will be created in the requested folder. This does not work if requested image is a png because resize method is chosen by the original filename, so oxdynimggenerator.php tries to resize nopic.jpg with method _generatePng, which does not work.
Steps To ReproduceDelete nopic.jpg in folder \out\pictures\generated\product\1\87_87_75
Request image /out/pictures/generated/product/1/87_87_75/wrongname.png

Expected: nopic.jpg is loaded
Actual: no image is loaded
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined

Relationships

related to 0006369 resolvedanton.fedurtsya morepics loads same image multiple times if nopic.jpg is missing 

Activities

preethi

2016-06-09 11:03

developer   ~0011636

Pull Request: https://github.com/OXID-eSales/oxideshop_ce/compare/master...preethi-sivasankaran:6291-nopic-generation-fails-if-image-not-jpg

robert blank

2016-09-30 16:42

manager   ~0011813

Pull request https://github.com/OXID-eSales/oxideshop_ce/pull/397 was backported to v5.3.2
A minor refactoring was done for v6.0