View Issue Details

IDProjectCategoryView StatusLast Update
0006254OXID eShop (all versions)2. ----- eShop backend (admin) -----public2015-11-18 11:17
ReporterAdrian.Kirchner 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.6 / 5.2.6 
Target VersionFixed in Version4.9.7 / 5.2.7 
Summary0006254: adminlog saves lowercased sql statements
DescriptionAt the moment oxid saves lowercased sql statements in the oxadminlog table [1] and therefore falsifies the actually executed statement.
For example if you try to track down problems related to oxconfig manipulation you will get into trouble while reimporting the corresponding statements because the encoding key is lowercased.

[1] https://github.com/OXID-eSales/oxideshop_ce/blob/aaf26f7e331b614a05997cce750ac9d7cdbca33c/source/core/adodblite/generic_modules/oxadminlog_module.inc#L7
Additional Informationpull request will follow
TagsNo tags attached.
ThemeNot defined
BrowserNot defined
PHP VersionNot defined
MySQL VersionNot defined