View Issue Details

IDProjectCategoryView StatusLast Update
0006137OXID eShop (all versions)4.12. Subshop handlingpublic2022-09-20 12:42
Reporterhendrikfreytag 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.9.4 / 5.2.4 
Target VersionFixed in Version 
Summary0006137: OXACTIVE in oxfield2shop is not used
DescriptionIf want to you use oxfield2shop to have different values for oxactive in master shop and subshop, it doesn't work.
Steps To Reproduce- In config.inc.php add OXACTIVE to $this->aMultishopArticleFields
- Create field OXACTIVE in oxfield2shop
- create subshop
- make Category Kiteboarding available in subshop
- deactivate Kiteboard NAISH MOMENTUM in mastershop
- activate Kiteboard NAISH MOMENTUM in subshop
- browse to categorie Kiteboards in master and subshop
- Kiteboard NAISH MOMENTUM is missing in subshop

(If you enter the direct link to the article page, everything works fine.)
Additional InformationMaybe \oxBase::getSqlActiveSnippet has to check oxfield2shop for a different value of OXACTIVE
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP VersionNot defined
Database VersionNot defined

Relationships

duplicate of 0007360 acknowledgedvilma_liorensaityte Lists models aren't using the table oxfield2shop 
related to 0006905 closed The view table oxarticle does contain the price of the parent shop, not the price of oxfield2shop. 

Activities

martinwegele

2015-04-28 16:57

reporter   ~0010920

Maybe related to 0005024?

s.krenz

2015-05-21 07:10

reporter   ~0010973

I had the same problem. After I cleared the whole cache, it's working as expected.

florian.auer

2015-05-21 16:00

reporter   ~0010978

Please provide a product version.

michael_keiluweit

2022-09-20 12:42

administrator   ~0014320

Marked this one as duplicate because the new entry contains more information.