View Issue Details

IDProjectCategoryView StatusLast Update
0006132module PayPalmodule PayPal - subpublic2019-04-18 17:56
Reporterkeywan.ghadami 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version3.2.1 
Target VersionFixed in Version5.2.4 
Summary0006132: POST to /index.php?cl=1 caused by redirect in the answers to the IPN call back causes exceptions
Descriptionwhen doing checkout with paypal, paypal module sends a correct notify to paypal.
e.g. somethink like:
https://yourdomain.com/index.php?cl=oePayPalIPNHandler&fnc=handleRequest&shp=1

after that paypal will make requests to this url.

Now the paypal module handles this request and on success it returns true to the calling shop framework which causes a redirect, that will force paypal to resend the request to a wrong url like this:

POST /index.php?cl=1&sid=oqh17aa4e53bhou6ea0r2koqn4

the "1" in the cl paramters is the true value returned by the paypal module in the handle request method.

Steps To Reproducemake a checkout with paypal, wait for the IPN call, and see the log files,

in access logs you will see several requests from the paypal server, correct one first then the broken requests caused by the redirect.

Additional InformationFILE: htdocs\modules\oe\oepaypal\controllers\oepaypalipnhandler.php
FUNKTION: public function handleRequest
LINE: 153

Solution: do not return boolean, instead return null.

Pitfalls: the redirect/bug stops the execution right after the IPN messages is handled. It might be necessary to something similar because else the shop framework may do other unwanted things.
TagsNo tags attached.

Relationships

has duplicate 0006253 closedQA oePayPalIPNHandler::handleRequest redirect cl=1 

Activities

anton.fedurtsya

2019-03-13 15:14

administrator   ~0012818

Hello, this issue is fixed with https://github.com/OXID-eSales/paypal/pull/48