View Issue Details

IDProjectCategoryView StatusLast Update
0006131OXID eShop (all versions)1.03. Basket, checkout processpublic2015-04-23 12:39
ReporterJaroslavHerber 
PrioritynormalSeverityminorReproducibilitysometimes
Status closedResolutionduplicate 
Product Version4.9.2 / 5.2.2 
Target VersionFixed in Version 
Summary0006131: Wrong error-message if the online-vatid-check-service is not available
DescriptionSince few days, the online-vatid-check-service is instable.
And if the service is offline, a wrong error-message is thrown in the order-address-form: ID_NOT_VALID

The reason you can find here: oxonlinevatidcheck::validate():
if $this->_checkOnline() is false, then ID_NOT_VALID is set as error.

oxonlinevatidcheck::checkOnline(...) returns false, if the online-service is not reachable.

It would be better, if the check is skipped, if the service is offline. Blocking the customers' order-process because of faulty third-party services is not good at all.
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
Database Versionany

Relationships

duplicate of 0006126 confirmedSven Brunk oxonlinevatidcheck: Business customers can't order with VAT-ID if check service is down 

Activities

QA

2015-04-23 12:39

administrator   ~0010898

Duplicate of 0006126.