View Issue Details

IDProjectCategoryView StatusLast Update
0006118OXID eShop (all versions)2.9. Statisticspublic2024-01-31 14:08
Reporterheinrich.franz 
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version4.9.3 / 5.2.3 
Target VersionFixed in Version 
Summary0006118: No/wrong charset in OXID german Report
DescriptionIf I've open report in demo shop https://demoshop.oxid-esales.com/professional-edition/admin/ (Statistiken -> ausgeben)

Instead of Suchwörter I got Suchwörter (wrong chars for german umlauts). I took a look at the source code the compiled report site and have seen that there is no charset set.

UTF-8 would probably fix it.
TagsStatistics
ThemeAll
BrowserAll
PHP VersionNot defined
Database VersionNot defined

Activities

heinrich.franz

2015-04-13 18:05

reporter  

martinwegele

2015-04-17 10:50

reporter   ~0010878

Actually the charset is set correctly in the header of the generated page to utf-8: https://github.com/OXID-eSales/oxideshop_ce/blob/v4.9.3/source/application/views/admin/tpl/report_pagehead.tpl#L5
But somehow the browser thinks it's iso. Strange...

Sven Brunk

2024-01-31 14:08

administrator   ~0016226

Reports have been discontinued since the ticket was filed