View Issue Details

IDProjectCategoryView StatusLast Update
0006114OXID eShop (all versions)1.03. Basket, checkout processpublic2015-04-27 11:47
Reporteranton.fedurtsya 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target Version4.9.3 / 5.2.3Fixed in Version4.9.4 / 5.2.4 
Summary0006114: No errors shown in step 4 if ordering sold out item in Subshop.
DescriptionIf trying to buy sold out product in subshop, no errors shown in step 4 on ordering.
Steps To Reproduce1. In Subshop! Add some products to basket
2. Go till checkout step 4
3. Go to admin and change stock of one item to 0 and set delivery status "If out of stock, offline"
4. Try to press Order Now button in step 4.
Additional InformationProblem appears, because of issue: 0006113.
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0006113 acknowledgedflorian.auer getArticle method of oxbasketItem must be refactored 
related to 0006070 resolvedanton.fedurtsya No errors after step 4 if offline product with some others in basket, and offine product is sold out 

Activities

anton.fedurtsya

2015-04-08 09:17

manager   ~0010849

fixing by turning off lazy loading in order creation stock validation.

anton.fedurtsya

2015-04-16 11:53

manager   ~0010874

in oxorder::validateStock():

$oProd = $oContent->getArticle(true, null, true);

so now all required logic will be called as required.