View Issue Details

IDProjectCategoryView StatusLast Update
0006042OXID eShop (all versions)1.05. Userspublic2015-02-26 17:40
Reportera4pkochendoerfer 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionduplicate 
Product Version4.9.3 / 5.2.3 
Target VersionFixed in Version 
Summary0006042: Facebook Connect doesn't work properly
DescriptionFacebook Connect is to use as single sign on to oxid esales shop. It's another way to get access as an user to someones shop. But if you sign on with facebook, you can use like, share and you can comment something, but you aren't registered as user.

I think when you get Facebook Data you can check if an user is already created with this email address and if not, you can relink to register site to register the person with the missing data. Missing data means, data which you can't get by Facebook API.

The normal usage of connect is, to register someone with Facebook to get an faster access to someone's service. It doesn't work!
Steps To ReproduceActivate Facebook Connect option, add App Data and then use "Login with Facebook".
You'll see the bug.
TagsFacebook
ThemeAzure
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

duplicate of 0005228 acknowledged Facebook connect does not login the user to the shop 

Activities

a4pkochendoerfer

2015-02-12 20:55

reporter  

bug_oxid.JPG (16,425 bytes)
bug_oxid.JPG (16,425 bytes)

eike_spriess

2015-02-19 10:24

developer   ~0010678

reproducable on demoshop. Same bug as reported in https://bugs.oxid-esales.com/view.php?id=5228

QA

2015-02-26 17:40

administrator   ~0010724

Bug is a duplicate of https://bugs.oxid-esales.com/view.php?id=5228