View Issue Details

IDProjectCategoryView StatusLast Update
0006030OXID eShop (all versions)4. ------ eShop Core -------public2016-06-07 13:35
Reporteritsabug 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.8.9 / 5.1.9 
Target VersionFixed in Version4.10.0 / 5.3.0 
Summary0006030: isLoaded() not working for oxcategory
DescriptionisLoaded() will never return true for a category, because $this->_isLoaded is not set when oxCategory::load() is triggered.
Steps To Reproduce1. Create a category: oxNew('oxcategory')
2. Load it with valid id: $category->load('id')
3. Check the return value of: $return = $category->isLoaded()

-> its always false.
Additional InformationHotfix:


public function load($sOXID) {

        $ret = parent::load($sOXID);
        if ($ret !== false) {
            $this->_isLoaded = true;
        }
        return $ret;

}
TagsNo tags attached.
ThemeAzure
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Activities

michael_keiluweit

2016-05-25 15:34

developer   ~0011603

https://github.com/OXID-eSales/oxideshop_ce/pull/391

anton.fedurtsya

2016-06-07 13:35

manager   ~0011630

Thanks Michael. I have just merged your pull request to our master and ported to 5.3 branch