View Issue Details

IDProjectCategoryView StatusLast Update
0005994OXID eShop (all versions)1.06. Search, Tagspublic2015-11-05 17:32
Reporterhendrikfreytag 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version4.8.9 / 5.1.9 
Target Version4.9.6 / 5.2.6Fixed in Version 
Summary0005994: Searchstring with umlauts gives wrong result in utf8 mode
DescriptionSearch for "öl" will also find "chocolate", because it contains "ol".
Steps To ReproduceSearch for "Träpez" and "Trapez" in a OXID eShop running in utf8 mode. Both will find e.g. "Trapez ION MADTRIXX".
Additional InformationDemoshops are not running in utf8 mode right now, so you can't reproduce it in our demoshops.
TagsSearch, UTF-8
ThemeAll
BrowserAll
PHP VersionNot defined
MySQL VersionNot defined

Activities

hendrikfreytag

2014-12-11 10:09

reporter   ~0010421

Demoshops are now utf8, so you can reproduce it there.
http://demoshop.oxid-esales.com/professional-edition

HR

2015-08-21 13:32

manager   ~0011169

Using MySQL collation utf8_german2_ci would fix this issue as it is caused by using MySQL search functionality.

It is not possible to fix this bug properly due to missing collation utf8_german2_ci for UTF-8 in MySQL 5.5 and lower (from MySQL v5.6 on collation is available).

A workaround from the code side would mean to risk performance issues e.g. by providing larger SQL queries.

If anyone haa a better idea how to fix this issue please feel free to send us a pull request on GitHub.