View Issue Details

IDProjectCategoryView StatusLast Update
0005966OXID eShop (all versions)5. ------ UpdateApp / Update ------public2014-11-28 08:32
Reportermartinwegele 
PrioritylowSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version4.9.0 / 5.2.0 
Target Version4.9.3 / 5.2.3Fixed in Version4.9.0 / 5.2.0 
Summary0005966: UTF8-update script throws fatal error (2)
DescriptionIf you try to switch the charsets and collations of the DB with OXID's update scripts according to https://www.oxid-esales.com/en/support-services/documentation-and-help/oxid-eshop/installation/oxid-eshop-update-installation/update-eshop-to-utf-8-encoding.html you will get this error:

Fatal error: Call to undefined method oxLang::getInstance() in /mnt/hgfs/supportvm54/lichtexpertin/update.php on line 193
Additional InformationAgain: That's because oxLang::getInstance was removed with 5.2.0 / 4.9.0: http://wiki.oxidforge.org/Tutorials/Removed_deprecated_source#Removed [^]
It says: "Use Registry getter instead - oxRegistry::getLang();"
TagsNo tags attached.
ThemeAll
BrowserAll
PHP Versionany
MySQL Versionany

Relationships

related to 0005963 resolvedsaulius.stasiukaitis UTF8-update script throws fatal error 

Activities

There are no notes attached to this issue.